09 toyota shutters upon start and shuts off

#1
Hello all!
I just signed up the forum moments ago because i have a problem with my 2009 toyota LE..
My car has 176k on the dash
-its driven daily but very light driving ( under 20 miles a day on average)
-And i recently used seafoam (straight to the gas tank) to help stop a rough idle
- After the application of seafoam, my car would stall while sitting at a stop sign and even when i put the car into the reverse gear
I went to autozone and the reader showed that my charcoal/evap canister needed to be replaced. so i went to local shop and had them run a diagnostic and they said it was all 4 spark plugs and 3 ignition coils that needed to be replaced and nothing came up for my evap canister.

The mechanic told me that the battery was initially low on charge and that the spark plugs had been soaked in gas so he pointed me in the direction of replacing 3 coils and all 4 spark plugs.

i replaced them myself and for a few days the car was running fine with some rough idles but now my car wont start at all.
"My corolla would attempted to start, to only shutter and turn off". on good days (rarely) the car would start but it would be rough with low power and later building back up.
Could this be the fault of a bad battery that need to be replaced ( its almost time for me to replace it)
or should i replace all the ignition coils and listen to the mechanic instead of the parts store reader?
--P.S my check engine light randomly comes on and turns off for the past year--
 

Betzy

New Member
#2
Hello all!
I just signed up the forum moments ago because i have a problem with my 2009 toyota LE..
My car has 176k on the dash
-its driven daily but very light driving ( under 20 miles a day on average)
-And i recently used seafoam (straight to the gas tank) to help stop a rough idle
- After the application of seafoam, my car would stall while sitting at a stop sign and even when i put the car into the reverse gear
I went to autozone and the reader showed that my charcoal/evap canister needed to be replaced. so i went to local shop and had them run a diagnostic and they said it was all 4 spark plugs and 3 ignition coils that needed to be replaced and nothing came up for my evap canister.

The mechanic told me that the battery was initially low on charge and that the spark plugs had been soaked in gas so he pointed me in the direction of replacing 3 coils and all 4 spark plugs.

i replaced them myself and for a few days the car was running fine with some rough idles but now my car wont start at all.
"My corolla would attempted to start, to only shutter and turn off". on good days (rarely) the car would start but it would be rough with low power and later building back up.
Could this be the fault of a bad battery that need to be replaced ( its almost time for me to replace it)
or should i replace all the ignition coils and listen to the mechanic instead of the parts store reader?
--P.S my check engine light randomly comes on and turns off for the past year--
Sorry, it seems you are experiencing some frustrating lack of results...This isn't an authoritative answer, but I would say spend the money on a new battery since you feel the old one is faulty anyways. Hope to hear this move got the job done and solved your frustration!
Batz
 

Attachments

#3
I appreciate your advice! the battery was one of the culprits and i'm taking the car in for final diagnostic. i'll keep this post informed if anything comes up. thank you again
 

Betzy

New Member
#4
I appreciate your advice! the battery was one of the culprits and i'm taking the car in for final diagnostic. i'll keep this post informed if anything comes up. thank you again
Oh ok. Glad you to know you needed the new battery anyways.
Hope at the end you get to the bottom of it and still keep the car.
 

Attachments

Top