94 won't start after manual transmission fluid change

#1
Hi all, about 2 weeks ago, my 1994 corolla started making a clunk when it was shifted into reverse (before releasing the clutch). It ran fine otherwise, but I still stopped driving it until I could figure out where the noise was coming from.

Today, I crawled under it and found some fluid that looked like transmission fluid, so I checked the level and it was a bit low (about 0.5-1cm below the bolt hole. I decided to replace the fluid and include transmission stop leak when refilling it.

Everything seemed to go fine. I undid the 24mm lower bolt, drained the fluid (which did not look or smell particularly burnt), replaced the lower bolt, and refilled via the bolt hole on the front. I used the 75W90 transmission oil recommend by the internet and the in-store guide book, as well as a bottle of Rislone stop leak that said it was recommended for all types of transmissions and transmission fluids, including manual.

Now, however, the car won't start correctly. The first time I tried, it started and ran really roughly for about 5-10 seconds before shutting itself off. I tried again, and can get it to start if I crank it for several seconds, but it runs super roughly (almost like the timing is way off or only one or two cylinders are firing). The second time I shut it off immediately rather than waiting to see if it would shut itself off.

I'm at my wits end for how I've managed to screw this up. I did not disconnect or remove anything other than the two bolts, I watched several videos for this model of corolla, so I am quite certain that I removed the correct bolts (also, I'm not a total idiot and know what a transmission looks like), and this car has never had any start up problems before.

Any guesses? Did I kill my car, and if so, how? Thanks

PS it was in neutral when I started it.
 
#2
One more thing I meant to mention. When I undid the nut to check the fluid level, it hissed like gas being released from a pressurized container. Is that normal?
 
#3
Update: I was eventually able to get it to start and stay running by feathering the gas pedal. Eventually it cleared and started running normally. The only thing I can think if is maybe there was a bit of crud in the fuel system that was dislodged by jacking up one side of the car
 
Top