wierd issue with CD player

#1
hi there ! first post!


years ago my wife hit the dash out of anger in her '11 corolla while i was driving and now i think the cd player is shorting, only years later... also we just had the airbag recall done so maybe they moved a wire doing that?

now the cd player rejects CDs and acts as if a CD is in it. Managed to get it to keep a disk in, and hopefully i dont have a whole collection but id like the CD player to work well even if i could listen to only one disk most of the time

im considering 3 things? fuses, or maybe the unit isnt plugged well, or maybe I should put an aftermarket one and sell the original (as a defective one)
 

ZeCorolla

I Love Corolla's!
#2
I'd start by taking out the headunit and checking the connections on the rear. Also check the fuses. If everything looks good, replug all of the connections and see if maybe something was slightly loose. If that doesn't solve it, your headunit may be internally damaged for some reason.
 
#4
It's ejecting the disk most hte time. try looking into the cd loading zone and see if the felt has been loosened and damaged. can try to ise a thin tool and carefully feel around ( oh no don't) you will not damage things but can see and feel that way if it is right or wrong.

then you'll need hte proper tools to take off the molding to get to the radio unit......

you have the imput, why not use your smartphone today and the AUx that is what I do I put a bluetooth module wired and my smartphone is plugged to power done. no more messing with cds or the unit. I like it to work totally agree.
 
#5
actually ive fixed it before by scrapping the inside with a bobby pin, trying to pull parts of the mecanism to reset... today i managed to switch the disk, so im not changing the unit.. yet XD

also tried a lot to force a disk in (it thinks theres one in but theres not) and let it eject the disk i forced in, but it can be stubborn sometimes...
 
Top